PHP is the programming language that WordPress, like most websites, is written in.


WordPress requires at least the 5.2 series of PHP releases to run on.

What PHP versions Shield Security plugin is compatible with?

Shield Security plugin is compatible with any PHP version from 5.2 up to the latest version of PHP (including 7.x).


Note: As from the major release v6.0, we've removed support for WordPress installations running PHP v5.2 for all new features. Previously existing features will still support v5.2, but all new developments will require PHP at least v5.4.0


More information on why we are removing Support for PHP 5.2 can be found here.


One important thing to note here is that, if you use some compatibility tool, i.e. PHP Compatibility Checker to check compatibility with Shield, it can throw warnings.


Example of the warnings for php7.2 compatibility checking

FOUND 3 ERRORS AFFECTING 1 LINE
 37 | ERROR | Extension 'mcrypt' is deprecated since PHP 7.1 and removed since PHP 7.2; Use openssl (preferred) or pecl/mcrypt once available instead
 37 | ERROR | Function mcrypt_create_iv() is deprecated since PHP 7.1 and removed since PHP 7.2; Use random_bytes() or OpenSSL instead
 37 | ERROR | The constant "MCRYPT_DEV_URANDOM" is deprecated since PHP 7.1 and removed since PHP 7.2

These warnings can be ignored as they're flagging "fallback" code for older PHP versions.